Mailgun is under DDOS attack
Incident Report for Rejoiner, Inc.
Resolved
Mailgun seems to be back to normal operation.
Posted over 1 year ago. May 20, 2016 - 18:34 UTC
Investigating
Our email provider Mailgun is investigating degraded performance due to DDOS attack. Mail delivery may be delayed.
Posted over 1 year ago. May 20, 2016 - 15:36 UTC